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SURPRISE!

YOU CAN CREATE YOUR OWN KEYBOARD SHORTCUTS

our Mac’'s mouse is great and all
that, but reaching and clicking can

be a time sink. Luckily, your Mac has

Keyboard shortcuts are great productivity
boosters—especially when you create your own.

ariot of keyboard shortcuts just waiting to
enhance your productivity. For example, did you know that
you can instantly access any application’s Preferences by
pressing Command-, (comma), or open a selected folder and
all its subfolders in List view by pressing Option-Command-
Right Arrow? Now you do—and you can discover many more
such time savers in Apple’s tech note number 75459; check
it out at the euphoniously named http://docs.info.apple
.com/article.html?artnum=75459.
= Even better, if you

don’t find a shortcut

for the action you want
shortcutted, you can create
yourown. Launch System
Preferences » Keyboard &
Mouse. Click the Keyboard
Shortcuts tab and then
click the plus-signicon at
the bottom left. A pane will
drop; in its Application

Menu Title: Save As..
Enter the exact name of the menu command

AT it L M
Click Add, arld Mlcrosnﬂ Word
will display the Save As pane
when you press Control-S.

pull-down menu, choose the application that you want

to create a keyboard shortcut for and then type the exact
name of the menu command that you want shortcutted.

For example, if you want to create a shortcut for Save As in
Word, you need to add the ellipsis after As (i.e., Save As...).
Then click your cursor in the Shortcut field and enter the
key-combination you want to use. Click the Add button and
you've just programmed a keyboard shortcut; the next time
you open that app, it’ll have your new shortcut. (Disclaimer:
In our experience, this technique works with most apps, but
not all, and sometimes we had to first open and close the
menu that the command was in before the new keyboard
command would activate.)

To remove a keyboard shortcut, scroll to the bottom of the
list in System Preferences » Keyboard & Mouse » Keyboard
Shortcuts, where you’ll find a section entitled Application
Keyboard Shortcuts. Select the shortcut you want to cut
short and click the minus-sign icon; the next time you open
the app it's related to, the shortcut will have vanished.

YOUR MAC CAN REPAIR ITSELF

ike you, any computer benefits from
good hygiene practices, but your

Mac brings its own toothbrush—it’s

Third-party disk utilities can be a godsend, but first
let your Mac try to heal itself.

called Disk Utility (/Applications). Simply
using it to repair disk permissions fixes a surprising number
of problems. To do so, Launch Disk Utility, select your startup
volume in the list on the left, click the First Aid tab if it doesn’t
auto-select, then click Repair Disk Permissions, and wait until
the process is completed. (Skip the Verify Disk Permissions
button—why bother if you want to repair them anyway?) You'll
natice that you can’t repair permissions on volumes that don’t
have Mac OS Xinstalled on them. So, who said life is fair?
You also have help for more-serious problems, such as
your Mac refusing to start up at all, and that help is again
Disk Utility—but we'’re
talking about the copy

+Tos FAPRIF & 5k O VUM, JSECT TH3 iCOR ) The 15t en the’ L and slick Repasr Disk.

=T regalr diek pecmis
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without changing amyehing
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choase Utilities > Disk Utley.

Repairing permissions for “Big Drive”
Detsrmaining come<d e permistions.

sien prablems on o gisk o7 volume that has Mac OF X instalied,

on the Mac OS X install
disc that came with
your Mac. Put that disc
in your Mac’s optical

R
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drive, and then start

Permissions repair complete
The arv s have been verified or repaived on the selectad volume

up while pressing the
C key—and be patient,
since starting up from
the optical drive takes
time. Select Utilities >
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Disk Utility reports that this drive
was only mildly unhealthy.

Disk Utility; when
Disk Utility launches,
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select your recalcitrant startup volume, click the First Aid
tab if need be, and then click Repair Disk. Don’t mess with
permissions this way—that install disc doesn’t know what
files have permissions for what. Run Repair Disk twice, first
on the volume and then on the drive it’s on.

You can repair a volume without your Mac OS X install
disc, but it requires a trip to your Mac’s pure-Unix
command-line interface: a dark, scary place where there’s
no Command-Z undo and you have to use your fingers for
typing, not pointing the mouse. Ready? Shut down your Mac,
then start it back up. As soon as you hear the startup chime,
press Command-S to enter Single-User mode. A Unix prompt
will eventually appear—if you get stuck in a cascading loop
of repetitive text, press Return once or thrice, and the prompt
should appear. You’re now deep in the unprotected bowels
of Unix—don’t get fancy, because one false move could bring
disaster. Instead, just type /sbin/fsck -fy and press
Return (fsck stands for file system check). Your Mac will run
a rather lengthy checkup on itself, and then, if anything’s
wrong, it will let you know and take a whack at fixing things.
When it informs you that all’s well, it never hurts to type
/shin/fsck -fy and press Return again, just to make sure.
When both you and your Mac are happy, type Reboot, press
Return, and you’ll return to the good ol’ Mac OS X interface.




MAC OS X HAS A SOLID BUILT-IN WORD PROCESSOR

ac 0S Xincludes a surprisingly
capable word-processing app:
TextEdit (/Applications). Here are

Once merely a replacement for the venerable
SimpleText, TextEdit is now all grown up.

just a few of our favorite TextEdit tricks;

more can be discovered in its Help system—and yes, TextEdit

can save in Word’s .doc file format.

STYLES In the Styles drop-down menu in TextEdit’s Ruler,
you can choose from five predefined styles. Or create your
own and add it to the list by selecting text in that style,
selecting Otherin the Styles drop-down menu, and clicking
Add To Favorites. You can also select text with all instances
of any style, change multiple instances, and more.

TABLES Maklngtables in TextEdit is as easy as pie. Choose
Format > Text» Table, and
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press Return first. When
your table appears, so will
the Table palette, in which
you can enter the number
of rows and columns you

It’s easy to customize your
bullet points in TextEdit’s Lists
pull-down menu.

want, choose both horizontal and vertical alignment, merge
and split cells, nest tables in tables, and choose both
background and border color, plus border thickness.

LISTS Creating bulleted and numbered lists is easy, too.
Type your list, select it, and then choose the type of list you
want from the List menu in the Ruler. You can also add text or
symbols as prefixes and suffixes to your numbers or bullets
by choosing Other in the List pull-down menu. Your creativity
will be limited to this document—your customized bullets or
numbers won’t appear in a new document’s Lists menu.
PROPERTIES You can identify and search for your TextEdit
documents using properties. Select File » Show Properties
(or Command-Option-P). In the Document Properties dialog
that appears, you can add any and all the info you want
Spotlight to be able to search for. A few caveats: Keywords
must be separated by commas; properties don’t apply to
plain-text files; and if you want to avoid the hassle of typing
the Author, Company, and Copyright properties for each
file, you can add them globally to each new document in
TextEdit> Preferences » New Document.

YOUR MAC CAN HELP YOU PROOFREAD

ou may already know that your
Mac can talk to you; what you

may not know is how helpful its

Your Mac can read you a story—which can be
mighty helpful if it’s one you wrote yourself.

text-to-speech powers can be when you
need to proofread a document. The reason this is so helpful
is simple: Studies have shown that when we read something
over that we recently wrote ourselves, we often skip overa
double word or an incorrectly placed word because we read
it the way we remember that we wanted it to be read. There
are three solutions to this mind game: First, you could come
back to the document a couple of days later, after you forget
what most of it says. Second, you could ask a friend ora
coworker to proofread it for you The third solution is the
quickest and easiest
of them all: Have
your Mac read your
document to you.
Before you turn your
Mac into an automated
proofreader, first
make sure that you'll
be able to understand
it and that it’ll know
when you want it to

e

i

-

start talking. Launch
System Preferences >
Speech and select the

Trust us—you do not want Hysterical
to proofread your documents!

Text To Speech tab. Click the Play button, and your Mac will
begin to talk—what it says depends on the voice chosen in
the System Voice drop-down menu. If the speech is close to
unintelligible, choose a more realistic voice—we’re partial to
Victoria and Bruce, but to each his or her own. You can also
choose how fast the voice speaks. Now check the box labeled
Speak Selected Text When The Key Is Pressed, click the Set
Key button to set the key command you want to use to tell
your Mac to start talking, and then close System Preferences.

Now, if you want to listen to your Mac read a Word
document, simply select the text you want your Mac to read,
then press your chosen key command, and the recitation
will begin. If you’ve written your document in TextEdit, you
can either use the same method as you would in Word, or
simply Control-click and choose Speech » Start Speaking in
the contextual menu that appears. Other apps sometimes
put their access to the Start/Stop Speaking commands in
application name > Services » Speech. Experiment—most
text-employing apps can be made to speak up.

By the way, text-to-speech is scheduled for a vast
improvement in the next version of Mac 0OS X, Leopard,
which is scheduled for release in the spring of 2007. We
sentimentalists hope that Zarvox won’t be out of a job.
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SURPRISE!

EVEN YOUR MAC’S EYE CANDY IS USEFUL

ashboard. For many it’s a love or hate,
oreven a love/hate, relationship.

But it can make you a multifaceted

Apple’s Dashboard widgets are a good start, but
the true gems can be found on the Web.

Macster—for example, a weatherman, IT whiz,

mathematician, cartographer, and designer. With Dashboard

you can be all of that and more—but only if you know your

widgets. Here's a baker’s dozen of the best.

1. AirCompare Track down the best airfare prices. (free,

www.widgetizer.com)

2. AirPort Radar Scan the ether for Wi-Fi signals—a must for

mobile 'Bookers. (free, www.macwireless.com)

3. Blood Alcohol Content Calculator Admitting that this

might be helpful to you is your first step toward recovery.

(free, www.alexjacque.com/bac)

4, CNN News Widget All the news, all the time. (free,

www.ejectmedia.net)

5. ColorBurn Get a new professionally designed four-color

palette each day, complete with hexadecimal values. (free,

www.firewheeldesign.com)

6. GMaps This unofficial interface for Google Maps may

:nsplre you to get out from behind your Mac once in a while.

—————————  (free, www.lokkju.com/blog/index

.php/category/projects/google-maps)
7.iCal Events

The Blood Here's one fewer

Alcohol excuse for missing

Calculator says those important

it's OK forour  meetings. (free,

editor-in-chief www.benkazez.com)

to drive, but 8. iStat Pro Next

he’s taking a time somebody calls,

cab anyway. “Status, Gladys?” you

can easily recite your current IP address, memory usage,
uptime, CPU load, and more. (free, www.islayer.com)

9. Mirror It’s just what you need to check your teeth after a
spinach-salad lunch. (free, www.balooba.se)

10. PCalc Use this when your calculations just have to use
Reverse Polish Notation—and for a whole lot more. ($19,
www.tla-systems.co.uk)

11, Sunlit Earth It’s 11:00 p.m.—do you know where your sun is?
(free, http://astronomy.physics.tamu.edu/Widget/SunlitEarth/)
12. WeatherBug Local Weather We don’t need no steenkeen’
Weather Channel! (free, www.weatherbug.com)

13. YouTube Widget Get instant access to all the content

on the greatest thing since sliced bread. (free, www.sport-
monkey.com)

MAKE YOUR OWN WIDGET

When Dashboard first appeared in April of 2005, making your
own widget wasn't exactly easy. Today, with applications

such as Widget Maker X ($16.50, www.lajdesign.com) and
Wecode ($15, www.widgetfactor.com), the task is much easier.
And Leopard (Mac OS X 10.5) will include two technologies

to further improve the lives of widgeteers: Dashcode and

Web Clip. Dashcode is a widget-building tool that includes a
collection of widget templates into which you can drag RSS
feeds, links, and the like to create your own custom, fully
functional widgets—it even includes a debugger. Web Clip is
even easier, but it doesn’t create custom widgets. Instead, you
set a Safari page to open in Dashboard, and then clip that page
to show only the content you want. Bonus: The clip remains live,
refreshed, and interactive. May a thousand widgets bloom!

YOU CAN REINSTALL MAC OS X AT WARP SPEED

Your Mac is only human—sometimes it needs a kick in
_ _the pants. Here’s how to do that quickly and efficiently.

ou've tried every trick in “Your
Mac Can Repair Itself,” p32,
and you're still staring blankly

at the spinning beach ball of doom,
the dreaded international “No!” icon (which replaced the
equally dreaded broken-folder icon in Mac 0S 10.2), or the
kernel-panic Curtain of Death. It's time to admit it: You need
to reinstall your system.

But that takes forever, right?
Not 50, Joe—here are the Mac 0OS X
Installer’s hidden options that can
both speed up the process of getting
your Mac back on its feet and save
space on your hard drive.
ARCHIVE AND INSTALL By using
Mac 0S X’s Archive And Install
option, you can get the benefits of
a fresh system and still save the
time and hassle of reinstalling and

If all you see when
you start your Mac is
this, it may be time to
reinstall your system.
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reregistering your software and resetting most preferences.
Pop your installer disc into your Mac’s optical drive and
restart while holding down the C key. The installer will
automatically launch after your Mac restarts; choose your
preferred language, click the arrow button, pick the volume
you want to install your new system on, agree to the various
legal mumbo jumbo, and then click the Options button in
the dialog that (finally) appears. In the pane that appears,
select Archive And Install and check the Preserve Users And
Network Settings check box. Now, when you install, your user
files will remain untouched and a good chunk of your system
settings will be rolled into a folder called Previous Systems.
You can’t start up from this system folder, but it will
contain all the old system’s preference files and other
important stuff you might need, and it will save you the time




and hassle of reinstalling many, if not all, of your current
applications. Note that if you checked the Preserve Users
And Network Settings check box, you might infect your new
system with whatever was plaguing your old system, but the
time and aggravation saved by doing so makes it worth the
risk. If you reinfect your system, just install it again with this
box unchecked.

TRIM YOUR INSTALLATION A full installation of Mac 0S

X contains all of the system’s text items in 15 different
languages—and odds are you don't speak all of them. So to
speed up your installation and save space (the languages
otherthan English take up 1.1GB total), disable the ones
you don’t need. After you get past the Install Options page
and click the Continue button, you'll see a Customize button
in the next dialog; click it, click the disclosure triangle next
to Language Translations in the pane that appears, and
then uncheck any and all languages that you’ll never use.

Brazilian Portuguese, anyone?

Also click the disclose triangle next to Printer Drivers and
uncheck any printer drivers you'll never use. If, for example,
you know you’ll never have an Epson (652MB), Canon
(345MB), or Lexmark (299MB) printer, you can save nearly
1.3GB of disk space and speed your installation process.

To continue, just click Install, then sit back and enjoy a
snappy installation.

QUIT THE SETUP ASSISTANT

After a few system reinstalls during which you didn’t check the
Preserve Users And Network Settings check box, you'll grow to
hate the Mac OS Setup Assistant. Well, you don’t have to suffer
through it—you only have to sit through the opening song and
dance; once the assistant gets to the first data-input screen,
simply press Command-Q to quit the assistant. Only do this if
you're a power-user type who knows how set up your Mac to
use available printers, networks, and the like.

YOUR MAC HAS CIA-LEVEL TECHNOLOGY

If you've got something to hide—be honest, now—
your Mac can help you hide it. Permanently.

hetheryou’re an undercover op
seeking the ultimate in security
for an upcoming project, or just

anormal civilian looking to impress your

friends by sending them password-protected files, your Mac
can help. Here’s how to step up the security foryour next
top-secret enterprise.

ENCRYPTFILES Ifyou have an important file that you're
looking to spice up with a little bit of security, encrypting

the file with a password is quick and easy. Simply open the
file that you want to encrypt, select File » Print, then click the
PDF button at the bottom-left corner of the Print window,

and select Encrypt PDF. Supply a password and you’ve just
created a locked copy of the document—the original remains
unlocked on your Mac.

USE FILE VAULT Initiating a full system lockdown is easy-
cheesy with File Vault—maybe a little too easy, considering
that there’s no easy way to bust back in if you forget your
password. Located in System Preferences » Security,

File Vault can encrypt all of

password, odds are that your files are totally, completely,
and irrevocably hosed.

DELETE SECURELY Simply trash-and-delete something

in today’s day and age, and nine times out of 10 it can

be recovered. It doesn’t take a crypto-wizard to find it,
either—your teenager’s nosy friend could probably do it.
Soto increase the odds that something you delete doesn’t
come back to haunt you, there are a couple of things you
can do. First off and most simply, if there’s a single item or
even many things on the hard drive that you want to delete,
just place it in the Trash, go up to Finder in the menubar, and
scroll down to Secure Empty Trash.

If you're selling your Mac, you’ll want to erase the entire
hard drive, and if there’s something on the drive that you
really, really, REALLy don’t want anyone to find—ever—open
Disk Utility (/Applications/

the files in your home (user
name) folder and make them
accessible only if you type

in a master password that
you've set. It also allows you
to set up a number of other
security features including
automatic logout aftera
specified number of minutes of
inactivity, disabling automatic
login, requiring a password

to wake from sleep oryour
screen saver, and requiring

a password to unlock each
secure system preference. Use
File Vault with care, however—
if you forget that master

e Y
an Security ‘
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= A master password must be created for this computer to provide
Ty asatety nat for accounts with FileVault protection,

An administrator of this computer can use the Master Password o reset the
password of any user on the computer. If you forget your password, you <an reset
the password 10 GAin access (o your hame folder sven if it's protected by
Filewault, Thig proviges protection for users who forges their login password,

Master Password: =
Verify:
2 Password Assiseant |
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Click the question-mark icon, and File Vault will suggest a
password ranging from simple to diabolical.

Utilities) and select the Erase tab.
Click on the volume you’re looking
to nuke in the left-hand list and
then click Security Options. Now,
will a seven-times overwrite
suffice, or do you need the full 35-
pass hyper-obliterator? And yes,
the seven and 35 passes mean
that the process will take seven or
35 times as long as a simple zero-
out, respectively—and that can

be a long, long time, depending
upon the size of your drive. Have

a terabyte drive and want to do
the full 35-pass erase? Take a
vacation to Tierra del Fuego while
your Mac churns away.

006 MacAddict 35




THERE’S MORE THAN ONE WAY TO EJECT A DISC

ou have a CD or DVD in your Mac’s [
optical drive that you want out of your |

Mac’s optical drive—simple, right? All |

Got a disc stuck in your optical drive? Don't panic—
just follow these escalating eviction procedures.

you need to do is select the disc’s icon and

drag it to the Trash—but sometimes the disc is stubborn and
won't eject. If that’s your problem, try the steps below.
1.Select the icon and press Command-E. If it’s still a no-go...
2. ..launch Disk Utility (/Applications/Utilities), select the
recalcitrant disc in the volume list on the left, and then either
click the Eject button, press Command-E, or choose File »
Eject Disk. If the disc is still being stubborn...

3. ..restart while holding down the mouse button. No? Then...
4, ..ifyou have a tray-loading optical drive, shut down your
Mac or put it to sleep, pry or slide open the drive’s protective
door, find the emergency-eject hole on the front of the drive

s i (its location varies
from drive to drive, and
some drives don’t have
one at all), and poke a
straightened paper clip
into the hole—firmly—

CD stuck in your
optical drive?
Sometimes Disk
Utility’s Eject
button can help.

Eject

until the disc pops out. If you can’t use this method ‘cause
your drive is slot-loading or is missing that helpful hole...

5. ...it"s time for your last resort, short of taking your Mac to
an Apple Authorized Service Provider: ejecting the disc using
an Open Firmware command. But before you try this, know
that this trick doesn’t work on all Macs; in fact, it doesn’t
work on any Intel-based Macs. To access the mighty—and
mighty bland—Open Firmware interface, restart your Mac; as
soon as you hear the startup chime, hold down Command-
Option-0-F. A white text-based screen will appear that’ll
either prompt you to release the keys or simply display an

ok prompt. At this prompt, type eject cd (even if it’s a DVD
that’s stuck in your drive). Press Return, and in a second

or two your disc will—should?—pop out of the drive and
another ok prompt will appear; type mac-boot, press
Return, and your Mac will resume its startup sequence until
you're greeted by a normal desktop.

YOUR MAC RUNS BETTER ON EMPTY

here comes a time when you
need to invest a bit of it—time,

that is. If you can put aside a |

| Well, not “empty,” per se, but your Mac will definitely
run snappier if your hard drive’s not stuffed.

good portion of a day or maybe even

a weekend to delete unnecessary files and apps from your
hard drive, there’s a good chance that it’ll make your Mac
run snappier, plus save you a few bucks that you'd otherwise
spend on a larger drive. It’s not a particularly pleasant
chore, so schedule it for when there’s a good game on the
radio; and no, we don’t mean the Raiders versus the Bengals
(unless, of course, you live in Cincinnati).

ZAP YOUR APPS We recommend starting with your
Applications folder; you can often get rid of some hefty
apps that you never use. Open that folder in list view and
press Command-J; in the dialog that appears, click the This
Window Only radio button and the Calculate All Sizes check
box. Wait for a bit until your file and folder sizes have all
been calculated,
then click the Size

| column to sort your

e = | appsfrom fattestto
E | most anorexic. Now
all you need to do is

ana 4 Appicavgn £ Awicann
93 e, 309.CH iadibie {51 Thig window crly
T 7 At iy

,. drag any chubby app
s you don’t need to the
BN e Trash. Betteryet, get

a copy of AppZapper

($12.95, on the Disc
or www.appzapper
.com), which also

Sorting your apps from chubby to
trim makes it easier to weed out the
unwanted plus-sizers.

gets rid of most apps’ preference files, caches, and other
associated files.

GET THE PICTURE AND FLICK THE FLICK Nextweed out your
Pictures and Movies folders in the same way. If you're like
us, you have thousands of pictures you’ve pulled from the
Web during the past decade, plus cute QuickTime flicks you
just had to watch—once. Admit it, that kitty-attack WMV file
was fun last year, but now it’s just eating up space.

TRASH CAREFULLY Remember that there are some folders
you don’t want to mess with because their contents are
required to keep Mac OS X running smoothly. Do-not-touch
folders include those named Library and System. You can,
of course, delete unwanted fonts from /Library/Fonts and
preference (plist) files and application-support files for apps
you no longer have from /Library/Preferences and /Library/
Application Support, but tread lightly. One simple rule: If you
don’t know exactly what you're trashing, don't trash it.

YOUR MAC CAN AUTO-TRASH

Late at night, your Mac automatically runs a series of important
maintenance scripts that, among other things, get rid of space-
hogging log files and caches. However, if you turn your Mac

off at night—or even put it to sleep—it won't run 'em. The good
news is that there’s a Dashboard wicdget named Maintidget
(free, on the Disc or www.giantmike.com) that allows you to run
the daily, weekly, and monthly maintenance scripts any time
your little heart desires.

36 MacAddict December 2006

MacAddict's how-to editor, Niko Coucouvanis; MacAddict’s editor-in-chief, Rik Myslewski; and just

plain Mac addict Logan Kugler are all chagrined that their Macs are so much smarter than they a




